Android studio 1.5.1: Could not find property ‘vectorDrawables’

If you’re using v2.0 or above of the Gradle plugin you have to use:

android {
  defaultConfig {
    vectorDrawables.useSupportLibrary = true
  }
}

If you hare using v1.5.0 or below of the Gradle plugin you need to add the following to your app’s build.gradle:

android {
  defaultConfig {
    // Stops the Gradle plugin’s automatic rasterization of vectors
    generatedDensities = []
  }
  // Flag to tell aapt to keep the attribute ids around
  aaptOptions {
    additionalParameters "--no-version-vectors"
  }
}

Don’t confuse gradle with the gradle plugin. Check the build.gradle in the root folder (or inside the module) to get the version used by the gradle plugin (check the line classpath 'com.android.tools.build:gradle:1.5.0')

Specifically to upgrade from com.android.tools.build:gradle:1.5.0.

  1. Edit /build.gradle and set:

    buildscript {
        ...
        dependencies {
            ...
            classpath 'com.android.tools.build:gradle:2.0.0'
            ...
        }
    }
    
  2. Edit /gradle/wrapper/gradle-wrapper.properties and set:

    distributionUrl=https://services.gradle.org/distributions/gradle-2.10-all.zip
    
  3. Edit your module(s)’ build.gradle and add:

    android {
        ...
        defaultConfig {
            ...
            vectorDrawables.useSupportLibrary = true
        }
        ...
    }
    

Leave a Comment