ANDROID STUDIO 3.0 upgrade : Error:Could not resolve all files for configuration ‘:app:xxxxxxxDebugCompileClasspath’

change dependency declaration

from

compile files('libs/commons-lang-2.4.jar')

to

implementation files('libs/commons-lang-2.4.jar')

I had the same problem, build -> clean project worked for me.

Change the classpath of Project Gradle to:

 classpath 'com.android.tools.build:gradle:3.1.0-alpha01'

OR

change distributionUrl of gradle-wrapper.properties to

distributionUrl=https://services.gradle.org/distributions/gradle-4.1-all.zip

Hope it helps you

Leave a Comment