Android Studio Gradle BuildTools Revision

I had the same problem this morning after updating to .6.0. You need to change you gradle version in /projectName/build.gradle

classpath 'com.android.tools.build:gradle:0.11.+'

Open your SDK manager and download the new version of the build tools 19.1 then change the following line in /projectName/moduleName/build.gradle

android {
  compileSdkVersion 19
  buildToolsVersion "19.1" //This version needs to be updated to 19.1 after SDK update

  ...

}

Then sync your gradle files and you should be good to go!

I didn’t realize that my errors changed when I changed buildToolsVersion "19.0.0" to buildToolsVersion "19.1.0" in my build.gradle.

The first error was:

Error: The SDK Build Tools revision (19.0.0) is too low for project 'android'. Minimum required is 19.1.0

The second error was a little bit different, but I didn’t see it:

Error: The SDK Build Tools revision (19.0.0) is too low for project ':CordovaLib'. Minimum required is 19.1.0

So I’ve also changed the build.gradle inside the CordovaLib folder, and the error disappeared.

I have just recently updated my android studio to 0.6.0, and it was giving me the same problem. But my build was 19.0.3, instead of 19.1.0. I changed the buildToolsVersion “19.0.3” to –> “19.1.0” which it forced the Gradle to download the updates. I restarted my Android Studio, and the error went away. Not sure exactly how to explain, but I think it forces it to download the patch off the Maven site, and does its justice behind scenes. And just as Gabriel Matusevich said, the build.gradle is located ProjectFolder -> AppFolder -> build.gradle

Exception: I havn’t completed tested this out, but I did notice the Gradle was downloaded from the site, I havn’t added or deleted code, or ran the application yet. So to be sure, remember the buildToolsVersion number you had before!

Leave a Comment