Android Studio: Why am i getting multi dex error on brand new Google Maps API project?

as quoted below:

Your probably compiling all of the play-services API’s using compile ‘com.google.android.gms:play-services:9.2.0’… Now we can selectively compile API’s to avoid dex limit of 64K. For Google Maps use com.google.android.gms:play-services-maps:9.2.0… – Loki Jul 1 at 19:01

Answer from Loki worked and was very simple to do.

setting up google play services

Go through this link just add the dependencies which you want in your application.
This will prevent 64k exceeding error.

Happy coding.

Leave a Comment