I am trying to debug my flutter app in my android mobile but I am getting this error in VS Code

Solution for I am trying to debug my flutter app in my android mobile but I am getting this error in VS Code
is Given Below:

Launching libmain.dart on Infinix X655C in debug mode…
libmain.dart:1
Checking the license for package Android SDK Build-Tools 29.0.2 in C:UsersJoshAppDataLocalAndroidsdklicenses
Warning: License for package Android SDK Build-Tools 29.0.2 not accepted.
Checking the license for package Android SDK Platform 30 in C:UsersJoshAppDataLocalAndroidsdklicenses
Warning: License for package Android SDK Platform 30 not accepted.
Build failed with an exception.
I am also attaching the full screenshot of the error.

Any help would be appreciated. Here is the image of the error

Yes @RavindraS.Patil, you were right. I had not accepted android licenses. After running flutter doctor and accepting the license, the error was gone.