I get an error whenever I do abjad.show() in python (abjad for LilyPond)

I believe it’s something to do with how LilyPond and abjad have connected because running a LilyPond file works fine and running abjad.Staff() and stuff works fine, but as soon as I try abjad.show(), I receive and error that I don’t know how to fix:

When I run abjad.show():

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:UsersMixtliAppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packagesabjadio.py", line 715, in show
    result = illustrator()
  File "C:UsersMixtliAppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packagesabjadio.py", line 83, in __call__
    string = self.string or self.get_string()
  File "C:UsersMixtliAppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packagesabjadio.py", line 159, in get_string
    lilypond_file = illustrate(self.illustrable, **self.keywords)
  File "C:UsersMixtliAppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packagesabjadillustrators.py", line 254, in illustrate
    return method(item, **keywords)
  File "C:UsersMixtliAppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packagesabjadillustrators.py", line 27, in _illustrate_component
    lilypond_file = LilyPondFile(items=[block])
  File "C:UsersMixtliAppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packagesabjadlilypondfile.py", line 1116, in __init__
    version = LilyPondVersionToken()
  File "C:UsersMixtliAppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packagesabjadlilypondfile.py", line 872, in __init__
    version_string = configuration.get_lilypond_version_string()
  File "C:UsersMixtliAppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packagesabjadconfiguration.py", line 479, in get_lilypond_version_string
    proc = subprocess.run(command, stdout=subprocess.PIPE)
  File "C:Program FilesWindowsAppsPythonSoftwareFoundation.Python.3.9_3.9.1776.0_x64__qbz5n2kfra8p0libsubprocess.py", line 505, in run
    with Popen(*popenargs, **kwargs) as process:
  File "C:Program FilesWindowsAppsPythonSoftwareFoundation.Python.3.9_3.9.1776.0_x64__qbz5n2kfra8p0libsubprocess.py", line 951, in __init__
    self._execute_child(args, executable, preexec_fn, close_fds,
  File "C:Program FilesWindowsAppsPythonSoftwareFoundation.Python.3.9_3.9.1776.0_x64__qbz5n2kfra8p0libsubprocess.py", line 1420, in _execute_child
    hp, ht, pid, tid = _winapi.CreateProcess(executable, args,
FileNotFoundError: [WinError 2] The system cannot find the file specified

I’m running this code on python3

Leave a Comment