Which is better, return value or out parameter?

If we want to get a value from a method, we can use either return value, like this:

public int GetValue(); 


public void GetValue(out int x);

I don’t really understand the differences between them, and so, don’t know which is better. Can you explain me this?

Thank you.

Return values are almost always the right choice when the method doesn’t have anything else to return. (In fact, I can’t think of any cases where I’d ever want a void method with an out parameter, if I had the choice. C# 7’s Deconstruct methods for language-supported deconstruction acts as a very, very rare exception to this rule.)

Aside from anything else, it stops the caller from having to declare the variable separately:

int foo;
GetValue(out foo);


int foo = GetValue();

Out values also prevent method chaining like this:


(Indeed, that’s one of the problems with property setters as well, and it’s why the builder pattern uses methods which return the builder, e.g. myStringBuilder.Append(xxx).Append(yyy).)

Additionally, out parameters are slightly harder to use with reflection and usually make testing harder too. (More effort is usually put into making it easy to mock return values than out parameters). Basically there’s nothing I can think of that they make easier

Return values FTW.

EDIT: In terms of what’s going on…

Basically when you pass in an argument for an “out” parameter, you have to pass in a variable. (Array elements are classified as variables too.) The method you call doesn’t have a “new” variable on its stack for the parameter – it uses your variable for storage. Any changes in the variable are immediately visible. Here’s an example showing the difference:

using System;

class Test
    static int value;

    static void ShowValue(string description)
        Console.WriteLine(description + value);

    static void Main()
        Console.WriteLine("Return value test...");
        value = 5;
        value = ReturnValue();
        ShowValue("Value after ReturnValue(): ");

        value = 5;
        Console.WriteLine("Out parameter test...");
        OutParameter(out value);
        ShowValue("Value after OutParameter(): ");

    static int ReturnValue()
        ShowValue("ReturnValue (pre): ");
        int tmp = 10;
        ShowValue("ReturnValue (post): ");
        return tmp;

    static void OutParameter(out int tmp)
        ShowValue("OutParameter (pre): ");
        tmp = 10;
        ShowValue("OutParameter (post): ");


Return value test...
ReturnValue (pre): 5
ReturnValue (post): 5
Value after ReturnValue(): 10
Out parameter test...
OutParameter (pre): 5
OutParameter (post): 10
Value after OutParameter(): 10

The difference is at the “post” step – i.e. after the local variable or parameter has been changed. In the ReturnValue test, this makes no difference to the static value variable. In the OutParameter test, the value variable is changed by the line tmp = 10;

What’s better, depends on your particular situation. One of the reasons out exists is to facilitate returning multiple values from one method call:

public int ReturnMultiple(int input, out int output1, out int output2)
    output1 = input + 1;
    output2 = input + 2;

    return input;

So one is not by definition better than the other. But usually you’d want to use a simple return, unless you have the above situation for example.

This is a sample demonstrating one of the reasons that the keyword exists. The above is in no way to be considered a best practise.

You should generally prefer a return value over an out param. Out params are a necessary evil if you find yourself writing code that needs to do 2 things. A good example of this is the Try pattern (such as Int32.TryParse).

Let’s consider what the caller of your two methods would have to do. For the first example I can write this…

int foo = GetValue();

Notice that I can declare a variable and assign it via your method in one line. FOr the 2nd example it looks like this…

int foo;
GetValue(out foo);

I’m now forced to declare my variable up front and write my code over two lines.


A good place to look when asking these types of question is the .NET Framework Design Guidelines. If you have the book version then you can see the annotations by Anders Hejlsberg and others on this subject (page 184-185) but the online version is here…


If you find yourself needing to return two things from an API then wrapping them up in a struct/class would be better than an out param.

There’s one reason to use an out param which has not already been mentioned: the calling method is obliged to receive it. If your method produces a value which the caller should not discard, making it an out forces the caller to specifically accept it:

 Method1();  // Return values can be discard quite easily, even accidentally

 int  resultCode;
 Method2(out resultCode);  // Out params are a little harder to ignore

Of course the caller can still ignore the value in an out param, but you’ve called their attention to it.

This is a rare need; more often, you should use an exception for a genuine problem or return an object with state information for an “FYI”, but there could be circumstances where this is important.

It’s preference mainly

I prefer returns and if you have multiple returns you can wrap them in a Result DTO

public class Result{
  public Person Person {get;set;}
  public int Sum {get;set;}

You should almost always use a return value. ‘out‘ parameters create a bit of friction to a lot of APIs, compositionality, etc.

The most noteworthy exception that springs to mind is when you want to return multiple values (.Net Framework doesn’t have tuples until 4.0), such as with the TryParse pattern.

You can only have one return value whereas you can have multiple out parameters.

You only need to consider out parameters in those cases.

However, if you need to return more than one parameter from your method, you probably want to look at what you’re returning from an OO approach and consider if you’re better off return an object or a struct with these parameters. Therefore you’re back to a return value again.

I think one of the few scenarios where it would be useful would be when working with unmanaged memory, and you want to make it obvious that the “returned” value should be disposed of manually, rather than expecting it to be disposed of on its own.

I would prefer the following instead of either of those in this simple example.

public int Value
    private set;

But, they are all very much the same. Usually, one would only use ‘out’ if they need to pass multiple values back from the method. If you want to send a value in and out of the method, one would choose ‘ref’. My method is best, if you are only returning a value, but if you want to pass a parameter and get a value back one would likely choose your first choice.

Additionally, return values are compatible with asynchronous design paradigms.

You cannot designate a function “async” if it uses ref or out parameters.

In summary, Return Values allow method chaining, cleaner syntax (by eliminating the necessity for the caller to declare additional variables), and allow for asynchronous designs without the need for substantial modification in the future.

Using the out keyword with a return type of bool, can sometimes reduce code bloat and increase readability. (Primarily when the extra info in the out param is often ignored.) For instance:

var result = DoThing();
if (result.Success)
    result = DoOtherThing()
    if (result.Success)
        result = DoFinalThing()
        if (result.Success)
            success = true;


var result;
if (DoThing(out result))
    if (DoOtherThing(out result))
        if (DoFinalThing(out result))
            success = true;

Both of them have a different purpose and are not treated the same by the compiler. If your method needs to return a value, then you must use return. Out is used where your method needs to return multiple values.

If you use return, then the data is first written to the methods stack and then in the calling method’s. While in case of out, it is directly written to the calling methods stack. Not sure if there are any more differences.

As others have said: return value, not out param.

May I recommend to you the book “Framework Design Guidelines” (2nd ed)? Pages 184-185 cover the reasons for avoiding out params. The whole book will steer you in the right direction on all sorts of .NET coding issues.

Allied with Framework Design Guidelines is the use of the static analysis tool, FxCop. You’ll find this on Microsoft’s sites as a free download. Run this on your compiled code and see what it says. If it complains about hundreds and hundreds of things… don’t panic! Look calmly and carefully at what it says about each and every case. Don’t rush to fix things ASAP. Learn from what it is telling you. You will be put on the road to mastery.

There is no real difference. Out parameters are in C# to allow method return more then one value, that’s all.

However There are some slight differences , but non of them are really important:

Using out parameter will enforce you to use two lines like:

int n;

while using return value will let you do it in one line:

int n = GetValue();

Another difference (correct only for value types and only if C# doesn’t inline the function) is that using return value will necessarily make a copy of the value when the function return, while using OUT parameter will not necessarily do so.

out is more useful when you are trying to return an object that you declare in the method.


public BookList Find(string key)
   BookList book; //BookList is a model class
   _books.TryGetValue(key, out book) //_books is a concurrent dictionary
                                     //TryGetValue gets an item with matching key and returns it into book.
   return book;

return value is the normal value which is returned by your method.

Where as out parameter, well out and ref are 2 key words of C# they allow to pass variables as reference.

The big difference between ref and out is, ref should be initialised before and out don’t

Please avoid using out parameters.

Although, they can make sense in certain situations (for example when implementing the Try-Parse Pattern), they are very hard to grasp.

Chances to introduce bugs or side effects by yourself (unless you are very experienced with the concept) and by other developers (who either use your API or may inherit your code) is very high.

According to Microsoft’s quality rule CA1021:

Although return values are commonplace and heavily used, the correct application of out and ref parameters requires intermediate design and coding skills. Library architects who design for a general audience should not expect users to master working with out or ref parameters.

Therefore, if there is not a very good reason, please just don’t use out or ref.

See also:

I suspect I’m not going to get a look-in on this question, but I am a very experienced programmer, and I hope some of the more open-minded readers will pay attention.

I believe that it suits object-oriented programming languages better for their value-returning procedures (VRPs) to be deterministic and pure.

‘VRP’ is the modern academic name for a function that is called as part of an expression, and has a return value that notionally replaces the call during evaluation of the expression. E.g. in a statement such as x = 1 + f(y) the function f is serving as a VRP.

‘Deterministic’ means that the result of the function depends only on the values of its parameters. If you call it again with the same parameter values, you are certain to get the same result.

‘Pure’ means no side-effects: calling the function does nothing except computing the result. This can be interpreted to mean no important side-effects, in practice, so if the VRP outputs a debugging message every time it is called, for example, that can probably be ignored.

Thus, if, in C#, your function is not deterministic and pure, I say you should make it a void function (in other words, not a VRP), and any value it needs to return should be returned in either an out or a ref parameter.

For example, if you have a function to delete some rows from a database table, and you want it to return the number of rows it deleted, you should declare it something like this:

public void DeleteBasketItems(BasketItemCategory category, out int count);

If you sometimes want to call this function but not get the count, you could always declare an overloading.

You might want to know why this style suits object-oriented programming better. Broadly, it fits into a style of programming that could be (a little imprecisely) termed ‘procedural programming’, and it is a procedural programming style that fits object-oriented programming better.

Why? The classical model of objects is that they have properties (aka attributes), and you interrogate and manipulate the object (mainly) through reading and updating those properties. A procedural programming style tends to make it easier to do this, because you can execute arbitrary code in between operations that get and set properties.

The downside of procedural programming is that, because you can execute arbitrary code all over the place, you can get some very obtuse and bug-vulnerable interactions via global variables and side-effects.

So, quite simply, it is good practice to signal to someone reading your code that a function could have side-effects by making it non-value returning.

Leave a Comment